CRM Form Creation Page Not Loading

Incident Report for Vendasta

Resolved

The issue affecting the CRM Form Creation page has now been resolved. Users should be able to create and edit forms through the CRM interface without any issues.

Our engineering team identified and addressed the root cause, and functionality has been fully restored. We’ll continue to monitor for stability.

Thank you for your patience.
Posted Jul 30, 2025 - 17:19 UTC

Identified

We are currently investigating an issue where the CRM Form Creation page is not loading for some users. As a result, users may be unable to create or edit forms through the CRM interface.

Our engineering team is actively looking into the root cause and we will provide updates as soon as more information becomes available.
Posted Jul 30, 2025 - 04:26 UTC
This incident affected: CRM.