All affected sites are now loading normally, and services have been restored.
Our investigation identified that a bot attack caused WP Cloud to throttle requests. As part of the mitigation, our team enabled an adaptive protection rule, which temporarily impacted some live traffic. Following the mitigation, the attack traffic dropped significantly, and service stability has been restored.
Our systems are now stable, and the websites should be loading normally. We will continue to monitor the environment closely to ensure ongoing stability and performance.
Posted Sep 03, 2026 - 12:20 UTC
Identified
We've identified the root cause of the HTTP 429 (Too Many Requests) errors affecting hosted sites and are currently deploying a fix. We'll continue monitoring and post another update once the fix is fully rolled out.
Posted Sep 03, 2026 - 11:44 UTC
Investigating
We're investigating reports of HTTP 429 (Too Many Requests) errors affecting multiple hosted sites. Our team is actively looking into the cause and we'll post updates here as we learn more.