Intermittent 504 Gateway Timeout Errors Affecting WordPress Hosting

Incident Report for Vendasta

Resolved

The fix has been successfully applied, and all affected sites are now operating normally.

Root Cause: Google Cloud Platform (GCP) performed a node pool upgrade, which resulted in changes to the underlying IP addresses. Since the newly assigned IP addresses had not yet been configured within the WP Cloud environment, connectivity issues occurred, impacting site availability.

The necessary IP configurations have now been updated in WP Cloud, and services have been fully restored. All sites are currently functioning as expected, and we continue to monitor the environment to ensure ongoing stability.
Posted Jun 16, 2026 - 19:35 UTC

Identified

Our Engineering team is actively investigating the root cause of the elevated response times and timeout conditions occurring between the web gateway and backend application services. We are reviewing infrastructure performance metrics and service logs to identify and mitigate the issue.
Posted Jun 16, 2026 - 16:35 UTC
This incident affected: Wordpress Hosting.