Degraded performance for web chat assistants, customer facing conversations, and AI workforce

Incident Report for Vendasta

Postmortem

Between 8:30 AM and 12:28 PM CST, our Conversations service, which powers much of the communication layer our AI assistants and messaging features rely on, experienced a performance degradation that affected message delivery and response times.
Timeline

8:30 AM — Our engineering team detected a minor performance degradation in the Conversations service and began investigating.
9:30 AM — As the impact grew, we escalated the issue to a full incident response.
Root cause — We traced the degradation to session exhaustion in our primary database for Conversations.
Response — We ran two workstreams in parallel: scaling our database capacity through additional replication, and increasing the session throughput available to the Conversations service. At the same time, we tuned our workflow orchestration layer to remain highly available and maintain throughput during session-constrained conditions.
12:28 PM — Service was restored, and the availability alert cleared.

We apologize for the disruption. A full post-incident review is underway, and we'll be implementing changes to prevent a recurrence.

Posted Apr 24, 2026 - 19:50 UTC

Resolved

This incident has been resolved.
Posted Apr 24, 2026 - 19:18 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Apr 24, 2026 - 18:44 UTC

Update

We are actively increasing system resources to stabilize performance while we continue to investigate the underlying root cause. We will provide another update as soon as more information is available.
Posted Apr 24, 2026 - 17:44 UTC

Investigating

We are currently investigating an issue with web chat assistants, customer facing conversations, and AI workforce. Conversations may stop responding after the initial greeting message. Affected users see the greeting, but follow-up messages do not receive a response and the conversation cannot continue.

Our team is actively investigating the root cause and working to restore normal conversations functionality.

We will provide another update as soon as we have more information.
Posted Apr 24, 2026 - 17:17 UTC
This incident affected: Partner Center and Business App.