Website Live Chat
Incident Report for Vendasta
Resolved
This incident has been resolved.
Posted Jun 22, 2024 - 17:15 UTC
Identified
We are currently experiencing issues with our Website's Live Chat feature, which is resulting in it not showing or working as intended. The team is currently investigating and we will provide an update once there is more information available.
Posted Jun 21, 2024 - 21:06 UTC
This incident affected: Website Pro.