Partner Center Outage

Incident Report for Vendasta

Resolved

This incident has been resolved.
Posted Apr 21, 2026 - 18:20 UTC

Update

The issue has been resolved, and the platform is working as intended once more.
Posted Apr 21, 2026 - 18:20 UTC

Monitoring

The team has deployed a fix, and we are seeing stability in Partner Center and Business App once more. We are still monitoring the situation and will provide an update once resolved.
Posted Apr 21, 2026 - 16:09 UTC

Investigating

We apologize that we are currently seeing an issue where Partner Center and Business App are not loading or loading intermittently. Our development team is looking into this, and we will provide an update once there is more information available.
Posted Apr 21, 2026 - 15:29 UTC
This incident affected: Partner Center and Business App.