Users are unable to access Multilocation Groups

Incident Report for Vendasta

Resolved

We are happy to inform everyone that the technical team has rolled back a recent change, resolving this issue.
Users should be able to access multilocation groups once more.
Posted Feb 13, 2026 - 18:31 UTC

Investigating

Currently, we are experiencing an issue where users are attempting to access the Multilocation Business app or partner admins attempt to impersonate a user to access a multilocation group; they are unable to go past the location selector screen. Our technical team is investigating potential causes and will provide updates as they are made available.
There is no workaround for this issue at this time.
Posted Feb 13, 2026 - 17:33 UTC
This incident affected: Multi-Location Groups.