Unable to view Manage Reviews and Analytics pages in Reputation Management

Incident Report for Vendasta

Resolved

This incident has been resolved.
Posted Oct 09, 2025 - 14:38 UTC

Update

The issue with accessing the Manage Reviews and Analytics in the Reputation Management product has been resolved and all areas are working once more as intended.
Posted Oct 09, 2025 - 14:38 UTC

Update

We are still monitoring this issue and will keep an eye on the system overnight.

We will provide another update tomorrow morning once we have more information from our developers.
Posted Oct 08, 2025 - 23:00 UTC

Update

We are continuing to monitor this issue as we are still seeing some inconsistencies when accessing the different areas.

We will provide another update around 4 PM CST.
Posted Oct 08, 2025 - 20:40 UTC

Monitoring

The team has implemented a fix for both the Analytics and Manage Reviews page in Reputation Management, and all are loading once more as expected. We are continuing to monitor the issue and will have a full resolution soon.
Posted Oct 08, 2025 - 18:19 UTC

Update

Our development team is still working on a resolution for this issue. We apologize for any inconvenience this outage may be causing.

We will provide another update within the next 2 hours once we receive more information
Posted Oct 08, 2025 - 16:16 UTC

Identified

We are currently investigating an issue where users are unable to view the Manage Reviews and Analytics pages in Reputation Management. The root cause has been identified, and we are working towards a fix. We will provide another update at 10 AM CST.
Posted Oct 08, 2025 - 14:13 UTC
This incident affected: Reputation Management.