Issues with emails sent from businessmail.io
Incident Report for Vendasta
Resolved
The issues with emails sent from businessmail.io have been resolved and emails are going out properly again.
Posted Aug 01, 2024 - 19:14 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Aug 01, 2024 - 16:08 UTC
Investigating
We are currently experiencing issues with emails sent from our main domain businessmail.io. These issues are currently impacting "Welcome" emails and emails sent through campaigns for partners that have not completed the Email Settings setup to use their own domain for platform emails.

If you completed the Email Settings setup to use your own domain/email address for platform emails, these emails should still be sending properly.

Our development team is working to resolve the issues and we will update this incident as more information becomes available.
Posted Aug 01, 2024 - 16:06 UTC
This incident affected: Partner Center.