Partner Center Outage

Incident Report for Vendasta

Resolved

The incident has been resolved, and all areas of our platform are once more functioning as intended.
Posted Jun 12, 2025 - 21:18 UTC

Monitoring

Google has resolved the issue, and you should be able to access the platform once more. We are currently monitoring to ensure stability.
Posted Jun 12, 2025 - 20:37 UTC

Update

We are continuing to monitor this issue with Google.

https://status.cloud.google.com/regional/americas
Posted Jun 12, 2025 - 19:17 UTC

Identified

We apologize for the inconvenience, but users are not able to load/access our platform partners.vendasta.com. This appears to be related to an issue on Google's end. We are looking into this and will provide an update once we have more information.

https://status.cloud.google.com/regional/americas
Posted Jun 12, 2025 - 18:15 UTC
This incident affected: Partner Center.