Task Manager accounts page fails to load

Incident Report for Vendasta

Resolved

This incident has been resolved.
Posted Oct 09, 2025 - 14:48 UTC

Update

The Accounts page and Reviews are loading in Task Manager once more.

We apologize once more for the inconvenience experienced during this outage.
Posted Oct 09, 2025 - 14:48 UTC

Update

We are still monitoring this issue and will keep an eye on the system overnight as the fix takes effect.

We will provide another update tomorrow morning once we have more information from our developers.
Posted Oct 08, 2025 - 23:00 UTC

Monitoring

We are seeing stability in the Task Manager account as the accounts page is loading once more without issues.

We apologize for the inconvenience this issue is causing and will provide an update once we have more information.
Posted Oct 08, 2025 - 18:48 UTC

Update

Our development team is still looking into this issue, and we will provide another update within the next 2 hours once we receive more information
Posted Oct 08, 2025 - 16:15 UTC

Investigating

We are currently investigating an issue where the accounts page in Task Manager fails to load. As a workaround, Task Manager accounts can be accessed through the Projects and Tasks tabs, or through Partner Center > Accounts > Manage Accounts. We will provide another update at 10:30 AM CST.
Posted Oct 08, 2025 - 14:28 UTC
This incident affected: Task Manager.