WordPress hosting is currently experiencing “500: An unexpected server error occurred.”

Incident Report for Vendasta

Resolved

The issue affecting our WordPress hosting environment has been fully resolved. Services are operating normally.

If you continue to experience any issues, please reach out to our support team.
Posted Mar 31, 2026 - 14:59 UTC

Investigating

We are currently experiencing an issue affecting some WordPress-hosted websites, resulting in “500: An unexpected server error occurred” messages on affected pages.Our engineering team is actively investigating the root cause and working to restore full functionality as quickly as possible.
Posted Mar 31, 2026 - 13:24 UTC
This incident affected: Wordpress Hosting.