Intermittent 504 Gateway Timeout Errors on WordPress Hosting

Incident Report for Vendasta

Resolved

Our engineering teams identified the underlying cause and implemented corrective measures to restore normal platform performance. We have continued to monitor the environment following the fix and have confirmed that services are operating as expected.
Posted Jun 16, 2026 - 14:02 UTC

Identified

We are currently investigating an issue affecting a subset of WordPress Hosting websites. These sites may experience intermittent 504 Gateway Timeout errors when accessing the frontend, the WordPress admin dashboard, or performing administrative actions.
Posted Jun 16, 2026 - 13:32 UTC
This incident affected: Wordpress Hosting.